Go Back   Orchid Forum Orchid Care > Orchid Care > Orchid Pests and Diseases

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-20-2013, 02:25 PM
sofiaee's Avatar
Member
 
Join Date: May 2013
Location: Texas
Posts: 127
Thanks: 47
Thanked 28 Times in 21 Posts
sofiaee is on a distinguished road
Something wrong with these roots?

I have a Prosthechea radiata orchid that I mounted. It was doing very well at first and throwing out tons of new roots. It still is but some of the new healthy roots have turned brown and the green tip has gone away. Here's some pictures, let me know if you have any idea what this is/how to fix it!

These pictures are from right after a watering
Attached Thumbnails
img_3341.jpg   img_5581-1-.jpg  

Last edited by sofiaee; 07-20-2013 at 07:52 PM.
Reply With Quote
  #2 (permalink)  
Old 07-20-2013, 05:21 PM
Senior Member
 
Join Date: Feb 2012
Location: maryland
Posts: 526
Thanks: 115
Thanked 218 Times in 179 Posts
snazzyboots is on a distinguished road
i don't see any pics
Reply With Quote
  #3 (permalink)  
Old 07-20-2013, 05:42 PM
denite25's Avatar
Member
 
Join Date: Aug 2011
Location: baltimore md
Posts: 444
Images: 5
Thanks: 55
Thanked 159 Times in 115 Posts
denite25 is on a distinguished road
ditto that.
__________________
denite
Reply With Quote
  #4 (permalink)  
Old 07-20-2013, 07:52 PM
sofiaee's Avatar
Member
 
Join Date: May 2013
Location: Texas
Posts: 127
Thanks: 47
Thanked 28 Times in 21 Posts
sofiaee is on a distinguished road
edited the post, can you see now?
Reply With Quote
  #5 (permalink)  
Old 07-20-2013, 09:14 PM
mrhappyrotter's Avatar
Member
 
Join Date: Dec 2012
Location: North Carolina USA
Posts: 138
Thanks: 2
Thanked 81 Times in 44 Posts
mrhappyrotter is on a distinguished road
I can't really say, just from the photos. What makes it difficult is that, in the short term, some of the consequences of over watering and under watering are virtually the same.

My assumption, though, considering it's mounted is that it's more likely to be that the humidity is too low or that you aren't watering the plant enough. So, I guess the first questions would be how often do you water, what's the humidity like and what are the temps?

If all those things check out, I'd also start looking into fertilizing/feeding. What kind of fertilizer(s) do you use, what strength and how often. There's a chance the plant is simply being feed too much or too strongly or that the fertilizer salts have built up. I'm basing this on the fact that the roots seemed to grow well for awhile, then started having issues.
__________________
Brains are so high in cholesterol.
Reply With Quote
The Following User Says Thank You to mrhappyrotter For This Useful Post:
Ladyofthelakes (07-20-2013)
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What did I do wrong? JYM Orchid Mounting 10 11-04-2011 04:10 AM
Right or Wrong? orchidea Orchid - hydroponic/semi-hydroponic 7 12-29-2010 10:53 PM
Repotting new phal- lots of rotten roots and black tips on roots orchid_newbie Newbie Questions 6 05-04-2010 07:50 AM
What am I doing Wrong? nonee Newbie Questions 10 05-06-2009 06:18 PM
What's wrong with this den? lilsoy Orchid Care Cultivation 5 08-28-2008 05:58 PM






Free Vote Caster from Bravenet.com Free Vote Caster from Bravenet.com


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.0
Orchid Forum

vBskin developed by: CreationLab